PHP, which is a recursive acronym for PHP: Hypertext Preprocessor, is among the most popular general-purpose server-side programming languages out there. Any site or web-based app created using PHP will run on a given server on the condition that a PHP module is enabled, which makes the language truly universal and it is not really a big surprise that there are a few million servers that support it and 100s of millions of PHP-driven websites hosted on them. PHP is preferred over HTML thanks to the fact that it allows you to build a dynamic site with an enormous number of options. A PHP-based community web portal, for instance, will show different web content to each visitor despite the fact that the page URL will stay unchanged. In comparison, HTML-based websites are static and the content on the pages can be modified only manually. Just like any other software program, PHP has different versions and the one that was used while creating a certain website must be available on the server in order for the site to run flawlessly.

PHP 4 and PHP 5 Support in Cloud Hosting

In case you get a cloud hosting plan from our company, you will never need to worry about whether your websites are compatible with the web hosting environment, since several PHP versions are available on our servers for the sake of your convenience. The Hepsia hosting Control Panel will allow you to choose PHP 5.5, 5.4, 5.3, 5.2 or 4 with only one mouse click and in case you’d like to change the version, the new settings will take effect straight away. In this way, several years of work on websites created with an older PHP version will not be in vain. Our web hosting platform will even permit you to use a different PHP version for each domain hosted in your account, which implies that you can run newer and older scripts simultaneously. Most hosting providers on the marketplace support one, sometimes two versions of PHP. Unlike them, we strongly think that you should be the one to pick the version that your very own sites will use.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Even if your sites were created with an older version of PHP, you will be able to host them in a semi-dedicated server account from us, since we support multiple versions running simultaneously on our servers and each one of them can be enabled for your account with just one click from our custom Hepsia hosting Control Panel. Other than the newest PHP 5.4 and PHP 5.5, we also offer support for 5.3, 5.2 and the older PHP 4. The latter has already been abandoned by the great majority of web hosting suppliers, but we hold that you should not be forced to modify a website that took years to develop, as older programming language syntax does not invariably suggest safety loopholes. Just the opposite, a properly maintained website using PHP 4 can be more secure than a badly maintained one using PHP 5. For your convenience, we’ll also offer you the possibility to specify a different PHP version for each single site within your account.